Issues with completing Vocab Games have been resolved. We apologize for the inconvenience during this time period and we will continue to monitor.
Posted Dec 21, 2024 - 09:13 EST
Update
We continue to actively work on remediating the issue. In the meantime, new attempts at Vocab Games won't be able to be completed, however, other assigned activities remain unaffected. We apologize for the inconvenience during this time period as we work to fully restore Vocab Game functionality.
Posted Dec 20, 2024 - 09:15 EST
Update
We continue to actively work on remediating the issue. In the meantime, new attempts at Vocab Games won't be able to be completed. We apologize for the inconvenience during this time period as we work to fully restore Vocab Game functionality.
Posted Dec 19, 2024 - 12:54 EST
Update
We are continuing to work on remediating the issue. In the meantime, new attempts at Vocab Games won't be able to be completed.
Posted Dec 19, 2024 - 11:13 EST
Update
Users may experience issues while completing Vocab Games. We have identified the issue and are working to remediate it.
Posted Dec 19, 2024 - 10:05 EST
Identified
Users may experience issues while completing Vocab Games. We have identified the issue and are working to remediate it.